安装桌面版CentOS 6.5,然后下载最新版的WPS For Linux Alpha 12 p4 (rpm)

因为系统是64位的,所以要安装一堆32位的依赖库:

#让64位的系统运行32位程序:

yum install glibc.i686 libstdc++.i686

# 安装WPS Linux的依赖库

yum install libICE.i686 libSM.i686 libX11.i686 libXext.i686 libXrender.i686 libmng.i686 libzip.i686 libpng.i686 fontconfig.i686 glib2.i686 cups-libs.i686 mesa-libGLU.i686

# 先忽略依赖检查安装

rpm -ivh kingsoft-office-9.1.0.4280-0.1.a12p4.i686.rpm --nodeps

最后,下载支持GLIBCXX_3.4.14的rpm,如libstdc++-4.7.2-8.fc18.i686.rpm,google下就可以找到下载地址

#解压rpm包

rpm2cpio libstdc++-4.7.2-8.fc18.i686.rpm |cpio -idmv

cp usr/lib/libstdc++.so.6.0.18 /opt/kingsoft/wps-office/office6/

cd /opt/kingsoft/wps-office/office6/

ln -s libstdc++.so.6.0.18 libstdc++.so.6

编辑 /usr/bin/wps,在#! /bin/bash下面一行加入

export LD_LIBRARY_PATH=/opt/kingsoft/wps-office/office6:${LD_LIBRARY_PATH}

至此,WPS在64位CentOS 6.5下的安装完成。

不过,WPS的Linux版本与win版本在功能上还是有不小的差距。